logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages<12
Options
Go to last post Go to first unread
mitchb  
#21 Posted : Tuesday, July 2, 2024 3:45:07 PM(UTC)
mitchb

Rank: Senior Member

Joined: 4/29/2015(UTC)
Posts: 73

Thanks: 4 times
Was thanked: 65 time(s) in 33 post(s)
Originally Posted by: epicycloid Go to Quoted Post
Originally Posted by: mitchb Go to Quoted Post
The correct format in feet/inches when using fractions is, for example 2' 6 1/2".


This bug occurs without using fractions, just whole number, e.g. 6' 4" will cause the line to jump from the drawn position.


I have done a lot of architectural work in this program using feet/inch dimensions. My first question is what fractional accuracy have you set? Feet/inches has a round off feature that is based on this setting, that is, the displayed dimension might be different than the actual dimension. I discovered this feature while framing a wall. I set my first stud and using the gripper copied a second stud and dragged it 1' 4”, repeat for next stud etc.. Get to the end of the wall and my last stud is off by an 1 1/4”. What happened? Not all the studs were exactly 1' 4” apart. The dimension displayed in the data box said they were but that was being rounded off to the nearest 1/4”. I was the victim of accumulated error.

In your case, consider that your line may contain a fraction internally in the computer that is not being shown in the data box due to round off. You can mitigate this issue by setting the fractional accuracy to 1/128 or enter the dimension directly into the data box. I'm not suggesting that this is some kind of a work around. The problem needs to be fixed. I just hope this info will be useful to you going forward after this is fixed.
thanks 4 users thanked mitchb for this useful post.
L. Banasky on 7/2/2024(UTC), GARLIC on 7/2/2024(UTC), damhave on 7/3/2024(UTC), epicycloid on 7/3/2024(UTC)
epicycloid  
#22 Posted : Wednesday, July 3, 2024 6:01:24 PM(UTC)
epicycloid

Rank: Guest

Joined: 6/15/2023(UTC)
Posts: 30

Thanks: 14 times
Was thanked: 11 time(s) in 7 post(s)
Thank you for your detailed explanation of that accumulated error behavior. That would certainly be frustrating if you couldn't find where that was coming from!

That said, per your suggestion, I did try changing the "fractional accuracy" to see if it had any effect. It didn't.

I continue to think this is just some obscure, but reproducible bug, that crept in when the fix for unit symbol inputs was done. Maybe you are using a version prior to the units symbol change, and therefore your version doesn't exhibit the behavior?

I only recently started using ViaCAD with V14 WIP 1623 (and then incrementally upgraded to SharkCAD Pro).

There was a bug around the time I started using ViaCAD / SharkCAD with the unit symbols, e.g. ' and " for feet and inches respectively, when they were typed into the input fields. That got fixed sometime between WIP 1623 and WIP 1641, I think.

>> I went back and found the mention of the feet-inch input fix in WIP 1638: WIP 1638 Feet-Inch Unit Setting

This "line jumping" behavior started after the input fix, and the it has continued to do the same thing in each version I have tried.

What version are you using? Perhaps I can downgrade and test?

Edited by user Thursday, July 4, 2024 11:13:19 AM(UTC)  | Reason: added link to WIP 1638 + typo

      --Jon

SharkCAD Pro – V14 (aka 14.1.0 = WIP 1641 or 1645 or 1654)
16" MacBook Pro – M2 Pro – MacOS Ventura 13.6.7
MPSchmied  
#23 Posted : Thursday, July 4, 2024 11:46:34 AM(UTC)
MPSchmied

Rank: Guest

Joined: 4/9/2017(UTC)
Posts: 510
Man
Germany

Thanks: 278 times
Was thanked: 138 time(s) in 106 post(s)
Originally Posted by: epicycloid Go to Quoted Post
Perhaps I can downgrade and test?
In versions 9 and 10, the same error occurs. I had accidentally used inches only instead of feet/inches during testing.
OS: Windows 10 | CPU: AMD Ryzen 7 2700 | RAM: 32 GB | Graphic: AMD Radeon RX Vega 56 | Shark FX 9 Build 1162 | Unit: mm
thanks 1 user thanked MPSchmied for this useful post.
epicycloid on 7/11/2024(UTC)
mitchb  
#24 Posted : Thursday, July 4, 2024 3:42:15 PM(UTC)
mitchb

Rank: Senior Member

Joined: 4/29/2015(UTC)
Posts: 73

Thanks: 4 times
Was thanked: 65 time(s) in 33 post(s)
epicycloid;

I'm seeing the same "line jumping" as you have described. To stop that, after drawing your line, you must correct the format in all the data boxes. Draw your line then tab into the length box and enter your length, tab into the X data box and re-enter the data using the correct format, repeat for the Y box, and Z box if needed. Now you can tap the return key and your line will be the correct length and not jump. Notice that all the data boxes again have the wrong format. To add another line all the above will need to be repeated. Far more trouble than it is worth. Your suggestion to use some other unit until this is fixed sounds good to me.

O.S. 14.5
SharkCAD 14 build 1654
thanks 4 users thanked mitchb for this useful post.
GARLIC on 7/4/2024(UTC), MPSchmied on 7/5/2024(UTC), epicycloid on 7/11/2024(UTC), L. Banasky on 7/11/2024(UTC)
epicycloid  
#25 Posted : Thursday, July 11, 2024 10:51:25 AM(UTC)
epicycloid

Rank: Guest

Joined: 6/15/2023(UTC)
Posts: 30

Thanks: 14 times
Was thanked: 11 time(s) in 7 post(s)
Originally Posted by: MPSchmied Go to Quoted Post
In versions 9 and 10, the same error occurs. I had accidentally used inches only instead of feet/inches during testing.


Wow, ok, that's further back than I imagined! Thanks for going that far back to check.

      --Jon

SharkCAD Pro – V14 (aka 14.1.0 = WIP 1641 or 1645 or 1654)
16" MacBook Pro – M2 Pro – MacOS Ventura 13.6.7
epicycloid  
#26 Posted : Thursday, July 11, 2024 10:54:50 AM(UTC)
epicycloid

Rank: Guest

Joined: 6/15/2023(UTC)
Posts: 30

Thanks: 14 times
Was thanked: 11 time(s) in 7 post(s)
Originally Posted by: mitchb Go to Quoted Post
Draw your line then tab into the length box and enter your length, tab into the X data box and re-enter the data using the correct format, repeat for the Y box, and Z box if needed. Now you can tap the return key and your line will be the correct length and not jump.


Thanks Mitch -- I will watch the other data box behaviors. It had not occurred to me that the values for X, Y and Z were in fact changing when I was just entering a new length.

And based on MPSchmied's testing and comment above, this issue has been around a lot longer than I imagined.

      --Jon

SharkCAD Pro – V14 (aka 14.1.0 = WIP 1641 or 1645 or 1654)
16" MacBook Pro – M2 Pro – MacOS Ventura 13.6.7
thanks 4 users thanked epicycloid for this useful post.
L. Banasky on 7/11/2024(UTC), mitchb on 7/11/2024(UTC), GARLIC on 7/12/2024(UTC), MPSchmied on 7/12/2024(UTC)
memphisjed  
#27 Posted : Friday, July 12, 2024 10:54:46 AM(UTC)
memphisjed

Rank: Senior Member

Joined: 12/19/2010(UTC)
Posts: 111

Thanks: 17 times
Was thanked: 7 time(s) in 7 post(s)
I found this error long ago, blamed myself- new to software is always user.. that was turbocad v low number.

My work around has been keep units set to inches and type the length as simple math
Feet needed * 12 + inches needed+ fraction in the data box. Works, in the same amount of buttons presses. The data entry math functions are key to so much.

thanks 1 user thanked memphisjed for this useful post.
MPSchmied on 7/12/2024(UTC)
Users browsing this topic
Guest
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.