logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
WORP3  
#1 Posted : Wednesday, July 04, 2018 2:46:19 AM(UTC)
WORP3

Rank: Guest

Joined: 10/13/2017(UTC)
Posts: 34
Netherlands

Thanks: 15 times
Was thanked: 1 time(s) in 1 post(s)
I've noticed that for some reason the file size of my viacad pro design just doubled in size while I only added some simple boxes. File size was around 32.7MB after reading this design and adding some simple things and reshuffled some parts, I saved again which takes a long time. Eventually it was ready saving but I've noticed that the filesize almost doubled to 64MB which was to say at least not what I've expected.

Is there a way to reduce the file size again?

WORP3  
#2 Posted : Wednesday, July 04, 2018 3:24:52 AM(UTC)
WORP3

Rank: Guest

Joined: 10/13/2017(UTC)
Posts: 34
Netherlands

Thanks: 15 times
Was thanked: 1 time(s) in 1 post(s)
Looking to all the menu options I did found a compact option which reduces the file somewhat to around 50MB still to large for what's in there.
Saving takes minutes while in the meantime windows tells me that the program isn't responding.

I'm using a Windows 10 x64 quad core i7 2.9GHz 16GB ram PC with internal SSD, ViaCad uses around 40MByte of memory after startup, 1.2GByte after loading design and up to 3GByte after working a bit with the design.

Edited by user Wednesday, July 04, 2018 3:26:05 AM(UTC)  | Reason: Not specified

posh.de  
#3 Posted : Wednesday, July 04, 2018 4:39:53 AM(UTC)
posh.de

Rank: Senior Member

Joined: 2/23/2007(UTC)
Posts: 410
Man
Germany

Thanks: 6 times
Was thanked: 17 time(s) in 15 post(s)
switch on all layers and unhide everything for checking the model content.

You may want check to import the file into a new, empty document and save then (to another file of course). Alternatively a copy&paste might do something similar maybe by losing structural information.
POSH GmbH
www.posh.de
thanks 2 users thanked posh.de for this useful post.
GARLIC on 7/4/2018(UTC), WORP3 on 7/4/2018(UTC)
MPSchmied  
#4 Posted : Wednesday, July 04, 2018 10:59:16 AM(UTC)
MPSchmied

Rank: Guest

Joined: 4/9/2017(UTC)
Posts: 205
Man
Germany

Thanks: 32 times
Was thanked: 10 time(s) in 9 post(s)
Maybe u can also using the option "clear undo on save". Thse idea with the new file is also good,i made this several times.
thanks 1 user thanked MPSchmied for this useful post.
WORP3 on 7/4/2018(UTC)
WORP3  
#5 Posted : Wednesday, July 04, 2018 3:56:25 PM(UTC)
WORP3

Rank: Guest

Joined: 10/13/2017(UTC)
Posts: 34
Netherlands

Thanks: 15 times
Was thanked: 1 time(s) in 1 post(s)
Thanks for the input guys.
Didn't know that there was such a "clear undo on save", will definitely look for that.

Splitting up the design or reduce the imported step file to more block like items will definitely help but in my opinion this should't be necessary for such a design. Working with this file is just fine, I wonder why it's taking sooo long to save that thing, even with the doubling of the output file, it's only 30 to 60 MByte which shouldn't take up minutes to save. Minutes in more like five+ or so.
posh.de  
#6 Posted : Friday, July 06, 2018 5:39:25 AM(UTC)
posh.de

Rank: Senior Member

Joined: 2/23/2007(UTC)
Posts: 410
Man
Germany

Thanks: 6 times
Was thanked: 17 time(s) in 15 post(s)
try if disabling "File > Preferences... > Filing > Save Preview Image" avoids the lagging during the save process of the document.
POSH GmbH
www.posh.de
thanks 1 user thanked posh.de for this useful post.
WORP3 on 7/8/2018(UTC)
WORP3  
#7 Posted : Sunday, July 08, 2018 8:49:15 AM(UTC)
WORP3

Rank: Guest

Joined: 10/13/2017(UTC)
Posts: 34
Netherlands

Thanks: 15 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: posh.de Go to Quoted Post
try if disabling "File > Preferences... > Filing > Save Preview Image" avoids the lagging during the save process of the document.


Thanks for pointing me to this setting menu. Although the time during save didn't alter but I could configure there that the undo is discarded during save. Nevertheless saving is very slow.
WORP3  
#8 Posted : Saturday, July 21, 2018 6:53:23 AM(UTC)
WORP3

Rank: Guest

Joined: 10/13/2017(UTC)
Posts: 34
Netherlands

Thanks: 15 times
Was thanked: 1 time(s) in 1 post(s)
I've tried all settings and although the filesize reduced a bit, it keeps very slow. Simplifying the models imported reduces the filesize to around half (~22MByte) but it was still slow.
In the end the only thing that worked was just the create an empty document and copy all of the design from my original file into the new empty one and the file size dropped to almost 4MByte and saving was as normal again. Probably something was corrupt inside that slow file which got the saving process stuck on....

Nevertheless thanks for the replies and input.
UGMENTALCASE  
#9 Posted : Saturday, July 21, 2018 2:14:54 PM(UTC)
UGMENTALCASE

Rank: Guest

Joined: 3/21/2017(UTC)
Posts: 437
Man
United Kingdom

Thanks: 15 times
Was thanked: 38 time(s) in 32 post(s)
I had the same thing building an assembly in Shark with the reference manager. I added and removed parts and the file stayed pretty bit, with seemingly loads of things on a layer, I started a new file did it again and the file was tiny. Straaaaaaannnnnggggeeeeee.
ViaCAD Pro 10 + Power Pack Pro
Shark CAD + Power Pack Pro
Windows 7 Pro- MSI GL72 6QC-32GB RAM
WORP3  
#10 Posted : Saturday, July 21, 2018 2:32:19 PM(UTC)
WORP3

Rank: Guest

Joined: 10/13/2017(UTC)
Posts: 34
Netherlands

Thanks: 15 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: UGMENTALCASE Go to Quoted Post
I had the same thing building an assembly in Shark with the reference manager. I added and removed parts and the file stayed pretty bit, with seemingly loads of things on a layer, I started a new file did it again and the file was tiny. Straaaaaaannnnnggggeeeeee.


Indeed it is strange, just made a new file selected everything of the old en copied it to the new and it saved like normal again. Before that it took minutes to get the saving done which was also strange as in the end it was only just over 20MBytes..
But glad that it's gone, almost don't wanted to save again :)

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.