logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Guest  
#1 Posted : Saturday, September 09, 2017 5:52:44 PM(UTC)
Guest

Rank: Guest

Joined: 8/27/2014(UTC)
Posts: 395

Was thanked: 12 time(s) in 11 post(s)
I have been successfully running ViaCAD 2D/3D Pro 8 on my Mac with OS X 10.13, and just installed v10. V10 either never opens, or immediately crashes once it opens. Why won't this run?

Without pasting the entire error report, this is the part that looked somewhat important ("Exceptions" towards bottom):

Process: ViaCAD 2D3D 10 [793]
Path: /Applications/ViaCAD 2D3D 10.app/Contents/MacOS/ViaCAD 2D3D 10
Identifier: com.encore.viacad2D3Dv10esd
Version: 10.0.0 (1316)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: ViaCAD 2D3D 10 [793]
User ID: 503

Date/Time: 2017-09-09 16:49:49.404 -0700
OS Version: Mac OS X 10.13 (17A360a)
Report Version: 12
Anonymous UUID: 426B9733-0051-DEF3-2D64-224B7E10B748


Time Awake Since Boot: 610 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_PROTECTION_FAILURE at 0x00007ffeef3ffe30
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]
Tim Olson  
#2 Posted : Saturday, September 09, 2017 9:44:13 PM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 4,837
United States

Was thanked: 171 time(s) in 151 post(s)
Because Apple has changed the way the OS behaves in 10.13 that is not compatible with ViaCAD or Shark, specifically some of the event handling processing.

We've made some changes to event handling in the current beta build should work on 10.13. A service pack is coming out shortly for all V10 products.

Tim

Edited by user Saturday, September 09, 2017 10:25:33 PM(UTC)  | Reason: Not specified

Tim Olson
ViaCAD/Shark Development Team
EvoSoft
Links to ViaCAD Resources
jgdeschamps  
#3 Posted : Wednesday, September 27, 2017 12:05:22 PM(UTC)
jgdeschamps

Rank: Guest

Joined: 9/27/2017(UTC)
Posts: 2

Any news regarding a release date for the service pack? I cannot use ViaCAD under macOS High Sierra...
Tim Olson  
#4 Posted : Wednesday, September 27, 2017 2:20:38 PM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 4,837
United States

Was thanked: 171 time(s) in 151 post(s)
Yes, Encore just released the service pack which also now supports 10.13. See this post.


http://forum.punchcad.com/default.aspx?g=posts&t=8919#post33568

Tim
Tim Olson
ViaCAD/Shark Development Team
EvoSoft
Links to ViaCAD Resources
jgdeschamps  
#5 Posted : Wednesday, September 27, 2017 2:40:58 PM(UTC)
jgdeschamps

Rank: Guest

Joined: 9/27/2017(UTC)
Posts: 2

Thank you, I appreciate the quick response. I already used the support request form you posted. Best regards...
vojins  
#6 Posted : Saturday, January 06, 2018 4:14:55 AM(UTC)
vojins

Rank: Guest

Joined: 1/6/2018(UTC)
Posts: 1


Version 9 and older ARE NOT compatible with High Sierra nor will they be updated to support High Sierra. - Not much professional. Whether at least I can get a discount for buying version 10
Users browsing this topic
Guest (4)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.