logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
nabed  
#1 Posted : Tuesday, April 03, 2007 3:47:01 AM(UTC)
nabed

Rank: Member

Joined: 2/18/2007(UTC)
Posts: 98

Why is curve display so bad in Concepts Unlimited.
Even in "superfine" splines with low curvature have a really bad resolution.
Comparing it with an old C3D Version (3.0) the display is less refined than the same curve in "coarse".

At Interpolated splines controlpoints lay far from the displayed "Curve".
Extruded surfaces become badly facetted (yes, in "superfine" too)

I attached screenshots from C3D and CU to illustrate the problem:
The same conic converted to spline, then converted to polylines:
while C3D displays the curve in 16 segments, CU displays only 2!

Is ther a parameter to define curve tolerances or curve precision?
Or is this a bug?

Ciao, Norbert
nabed attached the following image(s):
curves_C3D-CU.jpg (69kb) downloaded 7 time(s).

You cannot view/download attachments. Try to login or register.
lebeau  
#2 Posted : Tuesday, April 03, 2007 9:10:51 AM(UTC)
lebeau

Rank: Member

Joined: 2/21/2007(UTC)
Posts: 47

In CU under resolution there in an additional box to select even distribution of curves. Checking this box makes a big difference in display resolution and doesn't really slow down the computer. I think curves should all be on superfine with even distribution all the time.
jlm  
#3 Posted : Tuesday, April 03, 2007 5:13:04 PM(UTC)
jlm

Rank: Senior Member

Joined: 2/18/2007(UTC)
Posts: 1,054
Man
France
Location: Limours

Thanks: 79 times
Was thanked: 49 time(s) in 31 post(s)
Resolution, resolution, resolution...
Please !
JL
nabed  
#4 Posted : Tuesday, April 03, 2007 5:43:19 PM(UTC)
nabed

Rank: Member

Joined: 2/18/2007(UTC)
Posts: 98

@lebeau

I keep all elements (curves, surfaces and solids) in "superfine" resolution by default.
Checking "even disribution" didn't have any effect on curve segmentation.

The curve resolution is MUCH worse than it used to be in Vers.3 (siehe attached image in first post) and effects elements derived from these curves too (poor facetting of slightly curved solids).

Tim could You look into this?
As for now I have to go back to using C3D Vers 3.:eek:

Ciao, Norbert
Tim Olson  
#5 Posted : Tuesday, April 03, 2007 5:52:49 PM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 5,023
United States

Was thanked: 220 time(s) in 192 post(s)
>Tim could You look into this?

Somewhere along the line we switched to a different vectorization procedure because of the signficant speed it gave us. However, you should be able to define your own definitions(chordal deviations) for the resolutions with the resolution.ini file.
Tim Olson
Vice President Software Development
IMSI Design/Encore
giulio.piovene  
#6 Posted : Wednesday, April 04, 2007 1:56:42 AM(UTC)
giulio.piovene

Rank: Junior Member

Joined: 3/12/2007(UTC)
Posts: 13

nabed wrote:

Even in "superfine" splines with low curvature have a really bad resolution.


Same problem, superfine setting, see attachment

[ATTACH]18[/ATTACH]
giulio.piovene attached the following image(s):
curves.jpg (85kb) downloaded 7 time(s).

You cannot view/download attachments. Try to login or register.
nabed  
#7 Posted : Wednesday, April 04, 2007 3:04:55 AM(UTC)
nabed

Rank: Member

Joined: 2/18/2007(UTC)
Posts: 98

Quote:
However, you should be able to define your own definitions(chordal deviations) for the resolutions with the resolution.ini file.


I'd like to try that! Where do I find the render.ini file?

Ciao, Norbert
Tim Olson  
#8 Posted : Thursday, April 05, 2007 12:11:45 AM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 5,023
United States

Was thanked: 220 time(s) in 192 post(s)
Try putting the attached file in your Enivron folder. This overrides the resolution settings for curves and surfaces. Remove the "_" in front of the parameter you want to change. The values are angular deviations. Be aware that when you lower them you will increase calculation times.
File Attachment(s):
resolutions.ini.zip (1kb) downloaded 9 time(s).

You cannot view/download attachments. Try to login or register.
Tim Olson
Vice President Software Development
IMSI Design/Encore
jol  
#9 Posted : Thursday, April 05, 2007 1:09:08 AM(UTC)
jol

Rank: Senior Member

Joined: 2/26/2007(UTC)
Posts: 2,156

This kind of resolution overdrive should be in Concept's UI !!
nabed  
#10 Posted : Thursday, April 05, 2007 2:47:39 AM(UTC)
nabed

Rank: Member

Joined: 2/18/2007(UTC)
Posts: 98

Thanks Tim, that solved the problem!
But I have to agree with Jol that these resolution tweaks should be managable from inside CU.
Manually changing the resolution.ini file in a text editor and putting it into the environment folder seems kind of a hack, and surely is a far from elegant solution for a problem that has been brought up repeatedly by various user.

So I hope some "expert resolution setup" might be implemented in a future version of CU.

Thank You again for the quick help.

Ciao, Norbert
Tim Olson  
#11 Posted : Thursday, April 05, 2007 9:56:22 AM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 5,023
United States

Was thanked: 220 time(s) in 192 post(s)
>>This kind of resolution overdrive should be in Concept's UI !!

Yes, that's the plan.
Tim Olson
Vice President Software Development
IMSI Design/Encore
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.