logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
UGMENTALCASE  
#1 Posted : Saturday, May 25, 2019 12:54:12 AM(UTC)
UGMENTALCASE

Rank: Guest

Joined: 3/21/2017(UTC)
Posts: 548
Man
United Kingdom

Thanks: 18 times
Was thanked: 49 time(s) in 42 post(s)
Morning all,

So I recently started using the construction lines in an effort to fully constrain my sketches, and you know it works really well. The constraints do not work well going from and edge to a point, from one sketch to a solid. Most of the time you get something bizarre which no one would want.
So i need to move a slot/cut out in a part. It had construction lines, which I have to delete because when you try and extrude something with opened ended construction lines, it tells you there are gaps in the profile? Really?!?!?! So it's picking up construction lines as proper lines, and complaining about them having an open end? That's issue number one.

Issue number two is on the attached video. As I say I've had to remove the construction lines, and so trying to constrain the line to the edge. CONSTANT CRASHING! What is the issue here? I'm literally scared to do anything without saving all the time on the off chance it fails. You can't use undo whilst using constraints, everything turns to sh*t.

Any ideas? When are we going to see some stability?
File Attachment(s):
constant crashing.mp4 (1,241kb) downloaded 15 time(s).

You cannot view/download attachments. Try to login or register.
ViaCAD Pro 10 & 11 + Power Pack Pro
Shark CAD + Power Pack Pro
Windows 7 Pro- MSI GL72 6QC-32GB RAM
UGMENTALCASE  
#2 Posted : Saturday, May 25, 2019 1:00:13 AM(UTC)
UGMENTALCASE

Rank: Guest

Joined: 3/21/2017(UTC)
Posts: 548
Man
United Kingdom

Thanks: 18 times
Was thanked: 49 time(s) in 42 post(s)
So just to add to this. I have to delete the construction lines, so then the sketch is not fully constrained. So then what? Put more lines in so it works? I have noticed that a line changed to a centre line pattern works, and it doesn't have an issue with open ends

So it turned out the problem was the slot. It was extruded and subtracted. So I've had to undo it all, change the sketch then redo it all. Total waste of time

Edited by user Saturday, May 25, 2019 1:19:01 AM(UTC)  | Reason: Not specified

ViaCAD Pro 10 & 11 + Power Pack Pro
Shark CAD + Power Pack Pro
Windows 7 Pro- MSI GL72 6QC-32GB RAM
murray  
#3 Posted : Saturday, May 25, 2019 8:12:39 PM(UTC)
murray

Rank: Senior Member

Joined: 9/24/2014(UTC)
Posts: 252
Australia

Thanks: 5 times
Was thanked: 33 time(s) in 30 post(s)
These are 2D constraints, you can't constrain solids directly, use solids or solid features as reference for constraint, which probably has something to do with some of your unexpected results. They're restricted to workplane. I typically use variables to refer constraints on different planes to each other when direct geometric relationships aren't possible. I've done that using DCM 2D constraints in TurboCAD, Shark V7 and V8, and with FreeCAD's 2D constraints. What constraints are you trying to refer from construction or helper geometry that can't be managed referring to the sketch's own geometry?
UGMENTALCASE  
#4 Posted : Saturday, May 25, 2019 10:06:15 PM(UTC)
UGMENTALCASE

Rank: Guest

Joined: 3/21/2017(UTC)
Posts: 548
Man
United Kingdom

Thanks: 18 times
Was thanked: 49 time(s) in 42 post(s)
I know these are 2d constraints and that's how I'm using them. If you have a sketch on a face, the sketch should be positioned from the edges of the face, for example. How else does it get positioned relative to the part? Unless you put more geometry in, which unknowingly needs to be on a specific layer?
I did more playing and if the construction lines are in the construction layer, it's fine. Move them from that layer to another, it has an issue.
You can use solid edges, as it allows you to pick them. As a test I put construction lines in instead.
ViaCAD Pro 10 & 11 + Power Pack Pro
Shark CAD + Power Pack Pro
Windows 7 Pro- MSI GL72 6QC-32GB RAM
murray  
#5 Posted : Sunday, May 26, 2019 8:06:58 PM(UTC)
murray

Rank: Senior Member

Joined: 9/24/2014(UTC)
Posts: 252
Australia

Thanks: 5 times
Was thanked: 33 time(s) in 30 post(s)
I built a similar object to yours in Shark V8 as an extrusion of the end profile, drew a rectange as profile for the cut out and autoconstrained it, then tried to constrain the rectangle from the edge of the solid. It didn't crash, but it delivered the errors in the picture and deleted the constraints related to the end segment of the profile. I built the object again as a rail sweep of the profile, ie added a path for it that comprised one edge of the face that the cutout is drawn on, and was able to constrain it, from the corner that you indicate in the video, my assumption is that the constraint takes reference to the corner as the endpoint of the path.
File Attachment(s):
constraint expt.sfx (42kb) downloaded 1 time(s).
murray attached the following image(s):
errors.png (26kb) downloaded 7 time(s).

You cannot view/download attachments. Try to login or register.
UGMENTALCASE  
#6 Posted : Monday, May 27, 2019 12:43:10 AM(UTC)
UGMENTALCASE

Rank: Guest

Joined: 3/21/2017(UTC)
Posts: 548
Man
United Kingdom

Thanks: 18 times
Was thanked: 49 time(s) in 42 post(s)
Right, so what I'm saying is. I build a block. I then add that cut out. Other than putting in the construction lines, how else am I positioning that slot? Trouble is, if construction lines only function properly when in the construction layer, then if you have a big part, and turn on the layer visibility to adjust things, it could be a minefield.

Im6going to try adding a construction layer, as a 'sub layer' see if that works. At least it would get around the problem.

Doesn't explain, why when I ended up removing the subtract feature, removing the extrude and then adding the constraints again, it worked. Stability again, when things being modified are a couple of steps deep in the history tree, chances are it falls over.

I had another issue with the same part. It had little rads in it. I could not adjust the main profile sketch, without being bombarded with error messages. The only was to change it successfully was deleted the rads, and mod the profile. The rads were no where near the main sketch, where not in anyway linked to any edges or anything and it had a massive issue with them
ViaCAD Pro 10 & 11 + Power Pack Pro
Shark CAD + Power Pack Pro
Windows 7 Pro- MSI GL72 6QC-32GB RAM
UGMENTALCASE  
#7 Posted : Wednesday, May 29, 2019 6:00:16 AM(UTC)
UGMENTALCASE

Rank: Guest

Joined: 3/21/2017(UTC)
Posts: 548
Man
United Kingdom

Thanks: 18 times
Was thanked: 49 time(s) in 42 post(s)
Adding layers like this works when moving construction lines from the standard construction layer to the added layer
UGMENTALCASE attached the following image(s):
Untitled.jpg (44kb) downloaded 1 time(s).

You cannot view/download attachments. Try to login or register.
ViaCAD Pro 10 & 11 + Power Pack Pro
Shark CAD + Power Pack Pro
Windows 7 Pro- MSI GL72 6QC-32GB RAM
Tim Olson  
#8 Posted : Wednesday, June 05, 2019 4:50:15 PM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 5,007
United States

Was thanked: 214 time(s) in 188 post(s)
Would it be possible to send me the file? We have a service pack in works and I'd like to see if we can address this issue.

Thanks

Tim
Tim Olson
IMSI Design / Encore
UGMENTALCASE  
#9 Posted : Thursday, June 06, 2019 3:06:53 AM(UTC)
UGMENTALCASE

Rank: Guest

Joined: 3/21/2017(UTC)
Posts: 548
Man
United Kingdom

Thanks: 18 times
Was thanked: 49 time(s) in 42 post(s)
Hi Tim,

As above really, I've now changed the file. It just can't seem to handle changes done when rads are in the model. Something to look at though. Import a small stl file. Do a mesh to analytics convert. Then do a part repair, crashes instantly, every time
ViaCAD Pro 10 & 11 + Power Pack Pro
Shark CAD + Power Pack Pro
Windows 7 Pro- MSI GL72 6QC-32GB RAM
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.