logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
digitalphaser  
#1 Posted : Wednesday, November 16, 2016 5:20:19 AM(UTC)
digitalphaser

Rank: Senior Member

Joined: 4/17/2015(UTC)
Posts: 144
Man
Germany
Location: Berlin

Thanks: 9 times
Was thanked: 14 time(s) in 14 post(s)
Hi,
To my surprise and dismay, I saw a massive problem with the resolution or display performance in 10. version of viaCad Pro.

To demonstrate, I created two identical models with viaCad v9 and v10.

In the 9. version I see a smooth surface.

v9 resolution

In the 10. version I see the angular and rough and not accurate surface.

v10 resolution

In both versions I use same resolution settings.

resolution settings


I exported models as OBJ. Unfortunately, these problems are clearly visible in the rendering.

rendering 1
rendering 2


For this reason, I do not see now benefiting from the new 10 version. The latest models made with VC 10, are not suitable for close-up rendering.

Where is the problem?

digitalphaser  
#2 Posted : Wednesday, November 16, 2016 5:42:33 AM(UTC)
digitalphaser

Rank: Senior Member

Joined: 4/17/2015(UTC)
Posts: 144
Man
Germany
Location: Berlin

Thanks: 9 times
Was thanked: 14 time(s) in 14 post(s)
By the way, one more example. PowerPack Pro: Subdivision to NURB.

Super smooth mesh turns into a rough solid.

sd mesh to solid

I very hope that I am wrong. But I have not found a way to fix it.
Claus  
#3 Posted : Wednesday, November 16, 2016 9:50:58 AM(UTC)
Claus

Rank: Senior Member

Joined: 2/19/2007(UTC)
Posts: 317

Thanks: 9 times
Was thanked: 17 time(s) in 15 post(s)
I confirm, solids look horrible. Convert to surfaces and it will smooth out but as soon as you stitch to solid again the resolution drops. Viacad pro 1314.

Claus
Tim Olson  
#4 Posted : Wednesday, November 16, 2016 2:40:12 PM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 4,938
United States

Was thanked: 199 time(s) in 175 post(s)
>> I saw a massive problem with the resolution or display performance in 10. version of viaCad Pro.

Can you try the Precise option in Edit : Resolution?

If you need more then Super Fine : Precise you can do the following:

--Select Object
--Edit : Convert To Mesh
--Adjust the mesh parameters to desired density
--Cancel

Cancel will leave the display mesh attached to the solid. However, a regen will recalculate the mesh based on the display settings.


Tim

Edited by user Wednesday, November 16, 2016 2:43:31 PM(UTC)  | Reason: Not specified

Tim Olson attached the following image(s):
precise.png (70kb) downloaded 11 time(s).

You cannot view/download attachments. Try to login or register.
Tim Olson
ViaCAD/Shark Development Team
Links to ViaCAD Resources
rokoko  
#5 Posted : Thursday, November 17, 2016 12:46:51 AM(UTC)
rokoko

Rank: Senior Member

Joined: 9/28/2013(UTC)
Posts: 320

Thanks: 3 times
Was thanked: 38 time(s) in 34 post(s)
i already mentioned a similar problem here:

http://forum.punchcad.co...sts&t=8207#post31241
viacad pro 10 powerpackpro, viacad pro 9 german, mac os 10.8, 10.9
digitalphaser  
#6 Posted : Thursday, November 17, 2016 3:53:19 AM(UTC)
digitalphaser

Rank: Senior Member

Joined: 4/17/2015(UTC)
Posts: 144
Man
Germany
Location: Berlin

Thanks: 9 times
Was thanked: 14 time(s) in 14 post(s)
Thank you Tim for info!

Of course I have experienced all the possibilities. Unfortunately without result.

But today I realized that it works after the following sequence of actions:

1. I changed the resolution to "Very Fine" and check the following parameters.

Change resolution

2. It has not produced visible results. Then Right Mouse Click --> change resolution to "Super Fine".

Super Fine

3. And it really works!

Result

It really works. But the workflow is not obvious. I use viaCAd from 6.version. I have never had such problems with the resolution. I think that this problem needs to be improved.

rokoko  
#7 Posted : Thursday, November 17, 2016 6:12:28 AM(UTC)
rokoko

Rank: Senior Member

Joined: 9/28/2013(UTC)
Posts: 320

Thanks: 3 times
Was thanked: 38 time(s) in 34 post(s)
i think the problem is that any changes in edit->object resolution are not instantly applied. you need to apply in inspector or maybe any other command
viacad pro 10 powerpackpro, viacad pro 9 german, mac os 10.8, 10.9
Tim Olson  
#8 Posted : Thursday, November 17, 2016 12:19:02 PM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 4,938
United States

Was thanked: 199 time(s) in 175 post(s)
>>I think the problem is that any changes in edit->object resolution are not instantly applied.

Checking....
Tim


Tim Olson
ViaCAD/Shark Development Team
Links to ViaCAD Resources
Tim Olson  
#9 Posted : Friday, November 18, 2016 11:02:37 AM(UTC)
Tim Olson

Rank: Senior Member

Joined: 2/2/2007(UTC)
Posts: 4,938
United States

Was thanked: 199 time(s) in 175 post(s)
>>]i think the problem is that any changes in edit->object resolution are not instantly applied. you need to apply in inspector or maybe any other command

Thank you rokoko! Fixed in next upload.

Tim

Tim Olson
ViaCAD/Shark Development Team
Links to ViaCAD Resources
Jan Capek  
#10 Posted : Saturday, January 14, 2017 10:31:23 PM(UTC)
Jan Capek

Rank: Guest

Joined: 1/7/2017(UTC)
Posts: 1

Great! Just several days ago i sent a question with exact same problem to technical support. No answer so far, so it brought me here and I'm very happy there is some temporary workaround. Thanks a lot digitalphaser!
I bought V10 Mac recently after several years with V8 and couldn't work in it because of this. Its not a problem just of solids, but curves and surfaces aswell.
Its all a bit confusing. resolution of objects can be changed at several places and each place has different settings..
Another thing thats connected to this is viewport speed and responsiveness. There is a warning (slower) when activating precise facets and even distribution .. but to be honest its not fast at all even without these.

Jan

Edited by user Saturday, January 14, 2017 10:33:02 PM(UTC)  | Reason: Not specified

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.